
Електронни таблици - MS Excel
Публикувано от  legolas  на  11.02.2010, 17.57 

1. Общи принципи на работата с електронни таблици

a) определение: електронната таблица служи за съхраняване на информация в табличен вид, за 
изчисляване на зависимости  и анализ на данните, за построяване на диаграми и отчети.
За работа с електронни таблици се използва MS Excel, който е част от офис пакета на Microsoft.
Други приложения за електронни таблици: OpenOffice Calc, KOffice Spreadsheet, StarOffice Calc

Елементи
 

Работна папка
Съдържа поне 3 необятни таблици като числото им може да се променя и дефинира по избор 
предварително. Преминава се и се работи с всички едновременно

Работна таблица
Тази която е активна в момента и избрана от Разделителната лента с имената на всички таблици 
Работната област на екрана е разделена на РЕДОВЕ и КОЛОНИ. Всеки ред е означен с число ,а 
колоната с буква. Има 16 хиляди реда и 256 колони като екрана показва малка част от таблицата и 
има още 25 хиляди такива екрана.Всеки екран има рамка.

Клетка
При пресичането на ред и колона се получава клетка (cell)..Означава се с буквата на колоната
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и числото на реда А10, b2 и т.н и се нарича адрес на клетката, даващ местоположението на 
клетката спрямо началната точка на таблицата. Там се въвеждат данни (текст,числа,формули)Във 
всяка клетка се въвежда само 1 вид данна (или само текст или число,формула). В клетките могат 
да се записват следните типове данни: текст, число, дата или час, парична единица и формула.  
Първият знак, записан в клетката определя нейния тип. Единичният апостроф " ' " автоматично 
определя написаното като текст. Например ЕГН не се третира като число и може да се запише с 
апостроф пред него '8601037118.. При избор на клетка от ЕТ записаното, в нея се визуализира в 
реда за редактиране. Записаното в клетката може да се различава от това, което се вижда в нея. 
За редактиране на информацията, въведена в клетката се щраква два пъти в клетката или се 
посочва реда за редактиране (може да се използва и клавиша F2). Показва се мигаща вертикална 
черта и в ляво от реда за редактиране сe появяват бутони за:

потвърждаване на промените , което може да се извърши и с клавишите Enter, Shift+Enter, Tab, 
Shift+Tab;

отказ от извършените промени , или клавиш Esc;

Редактирането на избрана зона от клетки става като след въвеждане на промените се натиснат 
клавишите Ctrl+Enter за въвеждане на корекциите във всички клетки от зоната.

Формула

Въвеждането на формули задължително започва със знака равно " = ", защото той еднозначно 
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определя написаното след него като формула. Дава зависимост между 2 или повече клетки. Две 
или повече клетки образуват БЛОК наречен ЗОНА.Тя се определя от 1 и последната клетка на 
ред,колона или правоъгълна област(зона).Удобни са за операции над групи от клетки 
едновременно. Текущата активна клетка е оградена с Рамка показалец,ограждаща с тъмен цвят 
клетката.

    работа с 
документи в Excel
- работна книга (workbook) - документ с 
електронни таблици - представлява файл с 
разширение XLS
Отваряне на документ: File -> Open;
Нов документ: File -> New;
Съхраняване на документ: File -> Save или Save 
As; Save As Web Page - запис като интернет 
документ.

Затваряне на документ: File -> Close

Search - търсене на текст в таблици;

Properties - дава справочна информация за документа (автор, заглавие, съдържание на листите и 
други)

лист (sheet)  - част от документа, използва се за въвеждане на отделни електронни таблици
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За работа с листи се използва контекстното меню:
Insert - добавя нов лист;
Delete - изтрива лист;
Rename - преименува лист;
Move or Copy - премества/копира лист;
Select All Sheets - избира всички листи;
Tab Color - задава цвят на отбелязката;
View Code - включва режим на работа с Visual Basic.

 

- редове, колони и клетки - определят се със своите адрес, напр: ред 1, колона А, клетка А1, клетка 
C12 и т.н. - диапазон от клетки - задават правоъгълна област от избрани клетки, напр: B4:C10 

 

типове данни - задават се чрез меню File -> Cells или чрез контекстното меню Format Cells за 
избраните клетки
General - без определен формат
Number - числа (цели или дробни, знака за дробна част се определя от регионалните настройки в 
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контролния панел)

Currency, Accounting - валута
Date - дата - според регионалните настройки
Time - час от денонощието
Percentage - проценти
Fraction - математическа дроб (напр. 1/3, 1/2 и др.)
Scientific - експоненциално представяне на числата
Text - текстови данни
Special - за данни, характерни за държавата (социални 
осигуровки, телефонни номера, пощенски кодове и др.)
Custom - потребителски формат - може да се 
конструира от потребителя

Примери:

Важно! При въвеждане на дробни числа се съобразете с регионалните настройки на знака за 
отделяне на дробната част (символ "." или ","). При въвеждане на погрешен  символ Excel приема 
данните като текстов формат.

Важно! При въвеждане на числови данни е забранено ползването на всякакви символи, различни 
от цифри (напр: интервали, букви и др.). В противен случай данните се приемат за текстови.

Важно! При използване на формат General форматът на данните зависи от съдържанието на 
клетката (числа или текст). 

Редактиране на електронни таблици

а) копиране на данни: Edit -> Copy (CTRL + C), Edit -> Paste (CTRL + V) и Paste Special (за промяна 
на формата);
б) изтриване: Edit -> Cut (CTRL + X) при което данните за запазват в клипборда
    Edit -> Delete - данните не се запазват в клипборда (Del)
в) използване на клипборда - Edit -> Office Clipboard - показва всички данни в клипборда
г) отмяна на последното действие - Edit -> Undo (CTRL + Z)
д) повтаряне на последното действие - Edit -> Redo (CTRL + Y)
e) автоматично попълване на данни - Edit -> Fill -> Down, Up, Right, Left
ж) попълване на серии от данни - Edit -> Fill -> Series (въвеждат се поне две стойности в две 
съседни клетки, за да се определи закономерността при попълване на серията)
з) търсене на текст - Edit -> Find
и) подмяна на текст  - Edit -> Replace Когато се работи с по-големи ЕТ, бързото намиране на 
клетка, в която е записана определена стойност или текст, се затруднява. За тази цел Excel 
осигурява възможност за търсене и замяна чрез командата Edit - Replace (или само Find). На фиг.4 
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е даден прозорецът Replace.

 

Фиг. 4. Търсене и замяна на данни е ЕТ

 

 

 

В полето Find What се записва текстът, който се търси. Търсенето може да се извърши по редове 
или по колони (списък Search). Ако изпълняваме само търсене (Edit - Find), може да се зададе от 
списъка Look in, къде трябва да бъде намерен текста - в написаното от потребителя (Formulas), 
сред това което се визуализира (Values), или в невидимите бележки към някои от клетките (Notes). 
В полето Replace with се задава последователност, с която да се извърши заместването. Замяна 
може да се извършва само във въведеното от потребителя и затова

 

 

 

 

Промяна структурата на електронната 
таблица
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Excel осигурява следните възможности за промяна структурата на ЕТ, които се изпълняват за 
избрани елементи от таблицата:

Ø       изтриване на избрани редове и колони с командата Edit - Delete;

Ø       вмъкване на нови редове над избран ред и на колони пред избрана колона с командите 
Insert - Rows и Insert - Columns;

Ø       копиране (Edit - Copy) и изрязване (Edit - Cut) на клетки и зони от клетки, чието съдържание 
се записва в системния буфер (Clipboard)  на Windows, както и вмъкване (Edit - Paste) 
съдържанието му на определеното със светлинния маркер място;

Ø       премахване на клетки от структурата на таблицата с Edit - Delete и определяне посоката на 
преместване на останалите клетки Shift Cells Left или Shift Cells Up;

Ø       изтриване съдържанието на клетки или зони от клетки без да се премахват тези клетки с 
Edit - Clear - Contents;

Ø       копиране с вмъкване чрез командата Insert - Copied Cells, при което трябва да се определи 
посоката, в която да се изместят останалите клетки Shift Cells Right или Shift Cells Down;

Ø       специално вмъкване съдържанието на системния буфер с командата Edit - Paste Special, 
което дава възможност за копиране на формули, на формати на клетки, само на стойности и други.

 

к) вмъкване на:
- редове - Insert -> Rows
- колони - Insert -> Columns
- лист - Insert -> Worksheet
- графично изображение - Insert -> Picture
- специален символ - Insert -> Symbol
- символ за край на страницата - Insert -> Page break
- коментар  - Insert -> Comment
- блокова диаграма - Insert -> Diagram
- обект от друго приложение - Insert -> Object
- връзка към друг документ или Интернет адрес - Insert -> Hyperlink

л) сортировка на данни - Data -> Sort Сортират се избраните записи в създадения списък. Има 
възможност за указване на три критерия за сортиране като се избират последователно първичен 
критерий за сортиране, вторичен критерий и т.н. Те се задават в полето Sort By, което се получава 
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след изпълнение на Data – Sort. От падащия списък се избира името на полето, по което да се 
извърши сортирането. В полета Then By се избират втори и трети признак за сортиране, които 
действат ако има еднакви стойности при сортиране по първи или втори признак. Отдясно на тези 
полета са опциите за определяне реда на сортиране: Ascending – възходящ ред и Descending – 
низходящ ред. Имената  на колоните не участват в сортирането, ако е избрана опцията  Header 
Row. На фиг. 5 е даден прозорецът на командата Sort.

 

 

 

 

 

 

 

Фиг. 5. Избор на критерии за сортиране

 

м) филтриране на данни - Data -> Filter
н) вмъкване на външен файл с данни - Data -> Import External Data -> Import Data (Excel 
поддържа различни формати бази данни, текстови файлове и интернет страници)
о) проверка на данните за валидност - Data -> Validation (избира се валиден формат на данните, 
диапазон на изменение, подканващо съобщение, което да се извежда при избиране на клетката, 
съобщение, което да се извежда при въвеждане на невалидни данни)
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п) Когато в една клетка се появи последователността от знаци "########", това означава, че 
колоната не е достатъчно широка, за да покаже стойността на клетката. Трябва да се увеличи 
размера на колоната. Можете да използвате ръчното определяне на размера като поставите 
светлинният маркер на границата между две колони в реда за изобразяване на техните имена и 
когато той се превърне в двупосочна стрелка натиснете бутона на мишката и плъзгайте в желаната 
посока. Друг начин за определяне на точния размер на колона спрямо дължината на най-големия 
низ, записан в нея е със двойно щракване бутона, когато светлинният маркер е на границата между 
две колони и има формата на двупосочна стрелка, както е показано на фиг. 3.

 

Фиг. 3. Използване на светлинния маркер на границата между две колони

 

а) подравняване на текст
Format -> Cells -> Alignment или от контекстното 
меню Format Cells
Хоризонтално подравняване - ляво, дясно, 
центрирано, двойно подравнено

Вертикално подравняване - горно, долно, 
центрирано

Indent - задава отстъп отляво

Wrap text - разделя съдържанието на клетка на 
отделни редове

Shrink to fit - намалява размера на текста до 
стойност, позволяваща да се събере в клетката
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Merge cells - сливане на съседни клетки

Orientation - завъртане на текста в градуси

 

 

 

 

б) избор на шрифт

Format -> Cells -> Font

Font - наименование на шрифта

Font style - стил на шрифта

Size - размер (от 1 до 409 пункта)

Color - цвят на текста

Underline - подчертаване на текста

Effects - ефекти на шрифта (зачертан, с повишена или понижена позиция)   

в) рамки на таблицата:

Format -> Cells -> Border

None - без рамки

Outline - външни рамки

Inside - вътрешни рамки

Border - задават се рамки от потребителя

Line - задава вида на линията за рамките

Color - цвят на рамката 
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г) цвят на клетките и 

шаблон за запълване:
Format -> Cells -> Patterns

 

Color - цвят на фона

Pattern - вид на шаблона

за запълване

 

д) защита на клетките:
Format -> Cells -> Protection

 Locked - защитава

клетките от промяна

Hidden - скрива формулите

(защитата на клетките работи, само ако се включи защитата на таблицата чрез меню Tools -> 
Protect -> Protect Sheet)

 

 

 е) ленти с инструменти
View -> Toolbars

 

 

Standard - използва се за отваряне и запис на документи, предпечатна подготовка, печат, 
редактиране на текст, сортировка, диаграми
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Formatting

- използва се за форматиране на текста в таблиците, за сливане на клетки, за промяна точността 
на представяне на числата

 

 

 

Drawing - използва се за чертане на прости геометрични фигури, декоративен текст, вмъкване на 
графични изображения и др.

 

Серия от данни
 

Поредните номера представляват серия от данни, защото това е частен случай на аритметична 
прогресия. Следователно редица от числа, чиито стойности се образуват в съответствие с 
определена закономерност се нарича серия от данни. Тя може да бъде записана в ред или в 
колона на ЕТ. Excel предоставя средства за попълване на такива последователности. В първите 
две клетки от реда (колоната) се записват първите два елемента от серията данни. След това тези 
клетки се избират. Със светлинния маркер се посочва долния десен ъгъл на последната избрана 
клетка. Натиска се бутона на мишката и се плъзга в същия ред или колона.  Попълването е в 
съответствие с зададената закономерност.

Освен числови серии, в Excel е включена възможност за конструиране имената на дните и на 
месеците. Стандартните списъци за дни и дати са достъпни след изпълнение на Tools - Options в 
страницата Custom Lists. В полето List Entries могат да се въведат произволни списъци за дни и 
месеци, ако сте избрали NEW LIST в прозореца Custom Lists. С командата Add те се включват към 
стандартните списъци. На фиг.6 е даден прозореца на командата Options - Custom Lists.
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Фиг. 6. Създаване на списък от тип 
серийни данни
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